Flutter: 常见错误 import 'package:http/http.dart' as http;

2019-06-18

有时候,我们下载一个程序,会看到import 'package:http/http.dart' as http;,会出现错误。
主要原因时我们没有安装http库,只要我们安装了它,就不会报错了。

1、引入之前,我们要看看最新版本号:

https://pub.dartlang.org/packages/http#-installing-tab-

2、引入

找到pubspec.yaml,添加如下代码

dependencies:
  http: ^0.12.0+2

3、安装库

如图所示,点击Packages get 完成安装。
或者输入命令也可
flutter packages get
两种方式任选其一。

4、错误消失

最终你的import 'package:http/http.dart'; 错误消失。

@2020  TCODE    津ICP备13002520号-4